No free space found in temporary directories

Problem:
Beim Programmaufruf oder während der Nutzung von Amicron-Faktura oder Amicron-Mailoffice tritt folgender Fehler auf:

sort error
No free space found in temporary directories
operating system directive WriteFile failed

Ursache:

Weiterlesen

Neu bei Amicron-Faktura 11: Backup jetzt inkl. Datenbanküberprüfung

Bei der integrierten Datensicherung existiert in Amicron-Faktura 11 die neue Option „Die Sicherungsdatei nach der Datenbanksicherung überprüfen„. Dabei wird nach Erstellung der Backupdatei eine Testdatenbank mit der Extension „.Verify“ im Backupverzeichnis erzeugt, das Backup wird anschließend zurückgesichert und die Testdatenbank nach erfolgreichen Zurücksichern wieder gelöscht.

Diese Funktion dient, neben den Prüfen der Backupdatei, hauptsächlich dazu, eine defekte Datenbank zu erkennen, bei der zwar die Datenbankprüfung durch das Firebird-Tool gfix problemlos durchläuft aber später die Rücksicherung im Notfall nicht funktionieren würde.

Datenbank-Prüfung durchführen: Ist Ihre Datenbank fehlerfrei?

Da Amicron-Faktura und Amicron-Mailoffice die Daten in einer Firebird-SQL-Datenbank speichern, treten Datenbankfehler nur sehr selten auf.

Probleme können z.B. durch einen Stromausfall, Festplatten- und Speicherfehler oder Kopieren der Datenbank während des laufenden Betriebs entstehen (Details siehe hier). Diese machen sich allerdings nicht unbedingt sofort durch einen Programmfehler bemerkbar, da die Probleme innerhalb der Datenbank zunächst nur als Fehler markiert werden, so dass eine weitere Nutzung möglich ist.

Sie sollten deshalb regelmäßig prüfen, ob Ihre Datenbank fehlerfrei ist.

Dieser Beitrag zeigt Ihnen, wie Sie eine Prüfung durchführen können und führt erste Maßnahmen im Falle eines Fehlers auf.

Weiterlesen

Fehler beim Programmstart: unsupported on-disk structure

Problem:
Beim Start von Amicron-Faktura oder Amicron-Mailoffice tritt folgende Fehlermeldung auf:

Beim Öffnen der Datenbank ist ein Fehler aufgetreten:
TDBXError.unsupported on-disk structure for file C:\Dokumente und Einstellungen\All Users\Dokumente\Amicron-Data\Data.fdb  found 11.2, support 11.0

Ursache:
Weiterlesen

Fehler beim Programmstart: Cannot load dbxint30.dll. It may be missing from the system path. InterBase-Bibliothek gds.so.0 im Pfad nicht gefunden.

Problem:
Beim Programmstart von Amicron-Faktura / Amicron-Mailoffice erscheint die Fehlermeldung „Cannot load dbxint30.dll. It may be missing from the system path. InterBase-Bibliothek gds.so.0 im Pfad nicht gefunden.“

Lösung:
Weiterlesen

Fehler bei der Datenrücksicherung mit dem Firebird-Backupprogramm gbak

In diesem Beitrag wird auf die folgenden Probleme eingegangen, die beim Wiederherstellen von Firebird-Datenbanksicherungen (*.fbk) auftreten können:

– Fehler „Expected Backup-Version 1, 2, 3 … Found 9“
– Fehler während der Rücksicherung: „Ende der Datei (EOF) erreicht.“
– Fehler beim Start der Rücksicherung: expected backup description record

Weiterlesen

Gemeinsame Datenbank manuell einrichten

Die Datenbankdatei kann nicht nur durch die Installationsroutine eingerichtet werden, sondern auch „von Hand“.

Eine manuelle Einrichtung der Datenbank ist z.B. in folgenden Situationen notwendig:
Weiterlesen

Kann die Datenbank auf einem externen Laufwerk (NAS, USB-Festplatte) abgelegt werden?

Nein, das wird nicht unterstützt. Die Datenbank muss sich während der Nutzung auf einem internen Laufwerk befinden. Die Datensicherungsdatei (*.fbk) kann jedoch problemlos auch auf externen Festplatten erstellt werden.

Wie kann ich die Datenbank auf einen neuen PC umziehen?

Erstellen Sie zunächst auf dem alten Rechner eine Datensicherung, indem Sie den Menüpunkt „Extras > Datensicherung > erstellen“ aufrufen. Es wird eine Datensicherungsdatei mit der Dateiendung FBK erstellt, die alle Daten und Druckformulare enthält. Kopieren Sie die erstellte Sicherungsdatei anschließend auf den neuen Rechner.

Installieren Sie nun auf dem neuen Rechner Amicron-Faktura bzw. Amicron-Mailoffice (sofern noch nicht erfolgt). Über das Menü „Extras > Datensicherung > zurückholen“ können Sie die erstellte Datensicherungsdatei zurückholen.

Danach können Sie auf dem neuen PC mit den Daten weiterarbeiten.

Falls Sie die integrierte Dokumentenverwaltung nutzen, müssen Sie die Dokumente ggfs. manuell auf den neuen PC umziehen, da diese nicht in der Datenbank bzw. der Datenbanksicherung enthalten sind.

Wie kann der Firebird Datenbanktreiber aktualisiert werden?

Dieser Beitrag beschreibt, wie Sie die bei Amicron-Faktura und Amicron-Mailoffice mitgelieferte Firebird SQL-Datenbank aktualisieren können, falls z.B. durch ein altes Programm bereits eine ältere Version von Firebird eingerichtet ist oder auf dem Server Firebird nachträglich installiert werden soll.

Welche Firebird-Version wird unterstützt?

Weiterlesen